Alternativa a Adobe Flash en Firefox GNU/Linux

Una nueva solucion permite olvidarse del molesto y siempre desactualizado Adobe Shockwave Flash Plugin en Firefox, utilizando, en cambio, Fresh Player Plugin, el cual permite enmascarar el Pepper Flash Plugin de Chrome (diseñado por Google).

Si bien Chrome para Linux actualiza el plugin automaticamente con el navegador, el consumo de memoria RAM de este es bastante mayor al de Firefox, asi en una PC con escasa RAM (o si se utilizan muchas pestañas simultaneamente) Firefox es la alternativa mas razonable.

Esta solucion permite tener la ultima version del plugin de Chrome en Firefox, corriendo en GNU/Linux (Debian/Ubuntu/Archlinux/Fedora/Manjaro), con lo cual ya no seria necesario el molesto Plugin de Adobe.

Pasos:

 

1 – Eliminar  el Shockwave Flash Plugin de Firefox desde Menu -> Complementos -> Plugins

2 – Instalar freshplayerplugin de la siguiente manera:
                                         – En Debian:

                                          $ sudo add-apt-repository “deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/ vivid main”
                                          $ sudo apt-get update
                                          $ sudo apt-get install pepperflashplugin-nonfree freshplayerplugin                                         – En Ubuntu y derivados:

                                           $ sudo add-apt-repository ppa:nilarimogard/webupd8
                                           $ sudo apt-get update
                                           $ sudo apt-get install pepperflashplugin-nonfree freshplayerplugin

                                          – En Arch Linux, Manjaro y derivados:
                                           $ yaourt -S freshplayerplugin-git

                                          – En Fedora y derivados:
                                           $ su
                                           $ dnf -y install wget
                                           $ wget -P /etc/yum.repos.d/ https://raw.github.com/kuboosoft/postinstallerf/master/postinstallerf.repo
                                           $ dnf -y install freshplayerplugin

3 – Reiniciar Firefox
4 – Verificar en  Menu -> Complementos -> Plugins que este instalado y habilitado Shockwave Flash version 18 o superior..

Nota:
Si el plugin no es detectado o si se utiliza otras distribuciones, es recomendable crear con el editor favorito un archivo de configuración con la ruta “libpepflashplayer.so”

Con el editor Gedit por ejemplo sería:

gedit ~/.config/freshwrapper.conf

Y se agrega la siguiente línea en la que se reemplazará “ruta” y se guardan los cambios:

pepperflash_path = “/RUTA/PepperFlash/libpepflashplayer.so”

TESTEADO EN:
Probado en Debian Jessie, tanto en Iceweasel como en Firefox en la version 39.0, en las siguientes paginas:
 -You Tube (anda pero no se ve barra de controles, igual se puede pausar,reaudar, aunque flash en you tube no es necesario ya que soporta HTML5) ,
Facebook Juegos ( Galaxylife y Throne Rush sin problemas) ,
Taringa Juegos no funciona (Pide el de Adobe),
Spotify Online (Sin problemas),
Deezer (sin problemas),
Xvideos no funciona (Adobe).
Seguire actualizando la lista a medida que me tope con paginas con flash.

OTRA SOLUCION PARA ADOBE PLUGIN:

Si usas mucho alguna pagina en la que pide el plugin de Adobe proba esta otra solucion que permite cambiar la version del plugin de Adobe que lee FIrefox/Iceweasel, de esta manera el plugin nunca va a estar desactualizado (para Firefox) ya que la version nunca va a ser mayor a 11.2 (Adobe suspendio soporte para Linux).
Para hacerlo:
1Cerrar Firefox e ir a la carpeta  ~/.mozilla/firefox/xxxxx.default-xxxxxx/  (los xxxxx son numeros random)
2-Editar el archivo pluginreg.dat (sudo nano pluginreg.dat )
3-Buscar la seccion del plugin de Adobe, se ve asi:

libflashplayer.so:$
/usr/lib/flashplugin-nonfree/libflashplayer.so:$
11.2.202.491:$      ———–Cambiar a ——>>
11.3.202.491:$
1436908127000:0:0:0:$
Shockwave Flash 11.2 r202:$
Shockwave Flash:$

4Cambiar 11.2.202.491:$  por  11.3.202.491:$  y guardar cambios.

Nota:
Con esto se logra cambiar la version a los ojos de firefox, no del sistema, asi que cada vez que se actualize el plugin esto se va a sobreescribir y hay que volver a cambiarlo, para evitar cambiarlo en cada actualizacion se puede bloquear la version del paquete del plugin (flashplugin-nonfree en Debian) con el gestor de paquetes Synaptic facilmente (Buscar el paquete, seleccionarlo, luego menu Paquete-> Bloquear version ).
Claro que con esto el plugin no va a tener las actualizaciones de seguridad provistas por Adobe.
Esta seria la solucion ideal si no sois un paranoico de la seguridad, con esta solucion te van a andar todas las paginas que necesiten de flash sin problema.

Nota Original: http://www.taringa.net/posts/linux/18792640/Alternativa-a-Adobe-Flash-en-Firefox-GNU-Linux.html

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *