Que pueden hacer por “Lenny”

para la comunidad de los Debianeros/Debianitas:

En la lista de correo debian-devel-announce [0], mandaron un mail
pidiendo la colaboracion, tanto de usuarios como de developers,
con respecto al lanzamiento de Debian 5.0 (AKA: Lenny) que no pudo
ser realizado en Septiembre como estaba previsto por la cantidad
de bugs criticos.

Aca les dejo una lista de items que estan pensados para cualquier
tipo de usuario, para cerrar bugs abiertos y lograr que salga la
nueva version.
Tambien hay una lista para desarrolladores que la pueden ver en
el mail completo aca [1].

[0] http://lists.debian.org/debian-devel-announce/
[1] http://lists.debian.org/debian-devel-announce/2008/10/msg00000.html

* Si estan utilizando 'estable' (AKA: Etch), podrian considerar
 actualizar a "Lenny" y verificar que todo les funcione
 correctamente. Actualmente no hay ningun procedimiento propiamente
 dicho que este documentado, por  lo que la mejor manera para
 probar la actualizacion es:

1. Hacer un backup
2. Modificar tu /etc/apt/sources.list
3. Ejecutar 'aptitude update' para actualizar la lista de paquetes.
4. Ejecutar 'aptitude install dpkg aptitude apt' para tener la ultima
   version de estos programas.
5. Ejecutar 'aptitude full-upgrade'



Si se encuentran con que sucede algo que no deberia, por favor
reportenlo.
Si ya conocen de algun caso con algun paquete en particular,
reportenle un bug a ese paquete describiendo el problema que
hayan experimentado al actualizarlo. Si hay alguna actualizacion
que no puede ser solucionada y que deberia estar documentada
(por ej: hardware no soportado, paquetes removidos), por favor
reporten un bug contra el paquete 'release-notes'. (Puntos extra
si ademas del bug incluyen un parrafo para agregar en las
notas de lanzamiento). 

* Hablando de notas de lanzamiento[2]: Pueden fijarse en
 los bugs del paquete  'release-notes' e intentar colaborar,
 por ejemplo, comentando su experiencia  con los problemas
 ya reportados (si los han podido resolver o no, y como fue
 que lo hicieron)

  [2] http://bugs.debian.org/release-notes

* Instalar el paquete devscripts[3] (van a necesitar la version
  de  backports.org[4]) y ejecutar al comando:
  'rc-alert --include-dists TU'.
 Esto les devolvera una lista de bugs criticos abiertos
 para cualquier  paquete que tengan instalado. Teniendo en cuenta
 que si los tienen  instalados, es porque probablemente los
 esten usando y esten interesados  en ellos, asi que seguramente
  les interese que estos bugs sean cerrados 🙂

  [3] http://packages.debian.org/devscripts
  [4] http://www.backports.org/ 

 Tambien pueden colaborar tratando de reproducir bugs y
 comentando el resultado en el reporte del bug. Algunos son
 sencillos, donde el  mantenedor no ha tenido tiempo de trabajar
  en ello. Por ejemplo el bug  497290[5] no requiere de
 conocimientos tecnicos. Solamente necesita que  alguien con
 tiempo recopile los datos para el archivo de copyright.

  [5] http://bugs.debian.org/497290

* Si saben idiomas (ademas de castellano :)), podrian considerar
  colaborar  en los esfuerzos de traduccion. Mientras que es
  demasiado tarde para  traducir el debian-installer o los
  pasos de la instalacion a un nuevo  idioma para "Lenny"
 (quizas para el proximo release?), pueden traducir  las notas
 de lanzamiento a algun idioma no soportado aun. Si estan  dispuestos
  a hacerlo (lo que toma bastante tiempo, especialmente en la
 fase final), por favor contacten al equipo de localizacion
 en su idioma[6]  o a la lista debian-doc[7] en caso de que no
 haya un equipo en su idioma.
 Nota: En nuestro caso seria debian-l10n-spanish[8]

  [6] http://lists.debian.org/i18n.html
  [7] http://lists.debian.org/debian-doc/
  [8] http://lists.debian.org/debian-l10n-spanish/

estraido de: Lugar-Gral

2 Responses to Que pueden hacer por “Lenny”

  1. 123 dice:

    Una pena que se quiera hacer de Debian algo como los *Ubuntus, con plazos de tiempo para sacar nuevas versiones si o si aunque no este todo bien.
    En los *Ubuntus es ridículo tener que actualizar todo el sistema cada 6 meses o un año como mucho, y ahora una Debian Stable tiene una vida planificada de 18 meses + 12 meses de soporte adicional, osea 30 meses en total, cuando CentOS ofrece 5 años de soporte.
    Creo que las nuevas versiones de Debian Stable se tendrían que planificar por nuevas características a incluir, como una versión nueva del kernel, Xorg, Cups, LSB, u otros componente o características importantes del sistema, pero no por plazos estúpidos de tiempos (nueva versión cada tantos meses). También creo que Debian Stable debería incluir, de forma mas seguida, nuevos controladores para poder soportar nuevos dispositivos, tal como se hizo en esta versión de Debian Etch y se incluyo un nuevo Kernel (la versión 2.6.24) para dar soporte a nuevo hardware.
    En fin yo comencé con Debian, en la actual versión estable, Debian Etch, con la intensión de tener un sistema estable y fiable para utilizarlo todos los días (en producción), ya que había escuchado de que uno podía utilizar el sistema casi tal cual por muchos años, no como Suse Linux (mi anterior sistema) que tenía que actualizar cada un año,con los inconvenientes que esa tarea supone. Ahora no estoy seguro si voy a actualizar a Lenny o voy a migrar a CentOS, pues parece que las versiones Estables de Debian ya no son lo que eran, ya que según esta página http://bugs.debian.org/release-critical/ hay mas bugs en la versión estable que en la de pruebas ¡¿?!…

  2. juancarlospaco dice:

    Hola, yo uso Ubuntu,
    y las Versiones tienen 5 años de soporte igual que CentOS,
    tenes que buscar las que dicen “LTS”,
    las intermedias las podes pasar por alto,
    no trae problemas, mira te dejo el link:

    http://www.ubuntu.com/products/WhatIsUbuntu/serveredition

    salu2

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *